မင်္ဂလာပါ!

လှိုက်လှဲစွာကြိုဆိုပါသည်။ ယခု ပထမဆုံးအကြိမ် ရောက်ဖူးခြင်းဖြစ်ပါသလား? ဝင်ရောက် ဆွေးနွေး မေးမြန်းလိုပါလျှင် အောက်တွင်ဖော်ပြထားသော button များမှတဆင့် ဝင်ရောက် ဆွေးနွေးနိုင်သကဲ့သို့ အဖွဲ့ဝင်အသစ်အနေဖြင့်လည်း လျှောက်ထားနိုင်ပါတယ်။

MYSTERY ZILLION တွင် English သို့မဟုတ် Unicode ဖြင့်သာ အသုံးပြုခွင့်ရှိသည်။ ဇော်ဂျီ ၊ ဧရာ စသည်တို့ကို အသုံးပြုခွင့် မရှိ။ Unicode fonts များမှာ Mon3,Yunghkio, Myanamr3 စသည်များ အသုံးပြုနိုင်သည်။ Unicode Guide ကို ဒီမှာ Download ချပါ။ Zawgyi to Unicode Converter
Don't share ebook or software if nobody request. You can find free book websites on here. We are welcome for discussion or asking question instead.

PHP, SQL,APACHE in ubuntu

edited May 2010 in PHP
I want to run php in my ubuntu...what can i do???
i type lhttp://localhost i see my space that .php and .html.....
when i run html it is ok but
.php have got unknow file types with ? icon....i run it I only got open with.....what is that????
Help me???

မှတ်ချက်များ

  • edited November 2007 Registered Users
    ကိုဖုန်းရေ ကြည့်ရတာ ခင်ဗျား ဥူဗံတူ မှာ အပါချီ ရှိပြီးသားထင်ပါတယ်။
    ဒါကြောင့် Local Host နဲ့ .html extension ကိုကြည့်လို့ရတာပေါ့။
    PHP လိုချင်ရင်တော့၊ တစ် Package update လုပ်ရင်လုပ်၊ နှစ် PHP.net ကနေဆွဲချပြီး
    Install လုပ်ရပါမယ်။
    ကျွန်နော်ထင်တာမမှားဘူးဆိုရင်၊ Ubuntu ထဲက Package Manager ထဲ၀င်ပြီး
    PHP check box လေးကို check လုပ်လိုက်ရင် ရပါပြီ။
    ကျွန်တော် မသေချာပါဘူး။ မကိုင်တာကြာလို့မေ့လုပါပြီ။
    ( What I think is, Php Package is already
    contained in Ubuntu installation CD. So you just have to enable it or
    check the check box for installation.)
  • edited November 2007 Administrators
    kotharthar wrote: »
    ကိုဖုန်းရေ ကြည့်ရတာ ခင်ဗျား ဥူဗံတူ မှာ အပါချီ ရှိပြီးသားထင်ပါတယ်။
    ဒါကြောင့် Local Host နဲ့ .html extension ကိုကြည့်လို့ရတာပေါ့။
    PHP လိုချင်ရင်တော့၊ တစ် Package update လုပ်ရင်လုပ်၊ နှစ် PHP.net ကနေဆွဲချပြီး
    Install လုပ်ရပါမယ်။
    ကျွန်နော်ထင်တာမမှားဘူးဆိုရင်၊ Ubuntu ထဲက Package Manager ထဲ၀င်ပြီး
    PHP check box လေးကို check လုပ်လိုက်ရင် ရပါပြီ။
    ကျွန်တော် မသေချာပါဘူး။ မကိုင်တာကြာလို့မေ့လုပါပြီ။
    ( What I think is, Php Package is already
    contained in Ubuntu installation CD. So you just have to enable it or
    check the check box for installation.)
    packages.ubuntu.com မှာ PHP5 package တွေကို download ဆွဲချလိုက်ပါ..
    PHP5
    PHP5-common
    PHP5-cgi
    libapache2-mod-php5
    php5-mysql
    အဲဒီ package တွေလိုအပ်ပါတယ်ဗျာ..
  • edited December 2007 Registered Users
    kophone wrote: »
    I want to run php in my ubuntu...what can i do???
    Help me???

    အရင်းဆုံး XAMPP ကို အောက်ကလင့်မှာ Download လုပ်လိုက်ပါ...
    http://www.apachefriends.org/download.php?xampp-linux-1.6.4.tar.gz

    ပြီးရင် Console ထဲမှာ ခင်ဗျား Download လုပ်ထားတဲ့ File ရှိနေတဲ့ Direcotory အောက်ကိုသွားပါ..

    ဒီအောက်မှာ ပြထားတဲ့အတိုင်း ရိုက်ပါ...
    sudo tar xzvf xampp-linux-1.6.4.tar.gz -C /opt

    ဒါဆိုရင် လိုအပ်တဲ့ PHP Apache Mysql အားလုံးကို /opt အောက်မှာ Install လုပ်ပြီးသား ဖြစ်သွားပါလ ိမ့်မယ်...

    ခင်ဗျားရဲ့ Web Document တွေအတွက် Directory က /opt/lampp/htdocs ဖြစ်ပါလိမ့်မယ်...

    PHP ဖိုင်တွေကို Browser တစ်ခုခုနဲ့ မRunခင် Apache Server ကို အရင် Run ပေးဖို့ လိုပါလိမ့်မယ်
    sudo /opt/lampp/lampp start လို့ ရို်က်ပြီး Run ရပါတယ်...

    Windows မှာလို စက်စအတက်မှာ Apache Server ကို Automatic Run အောင် ဘယ်လိုလုပ်ရမလဲ ဆိုတာကိုတော့ နောက်ကြုံမှ ထပ်ပြောပါဦးမယ်...

    [ stup!x ]
  • edited December 2007 Registered Users
    ဟုတ်ပါ့ဟုတ်ပါ့ stupix အကြံကောင်းတယ်။
    ကျွန်တော်ကိုယ်တိုင် XAMPP ကိုသုံးနေပြီး။ ပြောပြဖို့မေ့နေတယ်။
  • xazxaz
    edited May 2010 Registered Users
    /opt is admin right. how can i access ?i can copy my web stuffs into htdocs folder only with command line.but i cannot access from browser(FireFox) my web documents!
    here my error >>
    Access forbidden!

    You don't have permission to access the requested object. It is either read-protected or not readable by the server.
    If you think this is a server error, please contact the webmaster ([email protected]).
    Error 403

    localhost (http://localhost/)
    Wed 12 May 2010 08:44:58 AM EDT
    Apache/2.2.14 (Unix) DAV/2 mod_ssl/2.2.14 OpenSSL/0.9.8l PHP/5.3.1 mod_apreq2-20090110/2.7.1 mod_perl/2.0.4 Perl/v5.10.
Sign In or Register to comment.