မင်္ဂလာပါ!

လှိုက်လှဲစွာကြိုဆိုပါသည်။ ယခု ပထမဆုံးအကြိမ် ရောက်ဖူးခြင်းဖြစ်ပါသလား? ဝင်ရောက် ဆွေးနွေး မေးမြန်းလိုပါလျှင် အောက်တွင်ဖော်ပြထားသော button များမှတဆင့် ဝင်ရောက် ဆွေးနွေးနိုင်သကဲ့သို့ အဖွဲ့ဝင်အသစ်အနေဖြင့်လည်း လျှောက်ထားနိုင်ပါတယ်။

MYSTERY ZILLION တွင် English သို့မဟုတ် Unicode ဖြင့်သာ အသုံးပြုခွင့်ရှိသည်။ ဇော်ဂျီ ၊ ဧရာ စသည်တို့ကို အသုံးပြုခွင့် မရှိ။ Unicode fonts များမှာ Mon3,Yunghkio, Myanamr3 စသည်များ အသုံးပြုနိုင်သည်။ Unicode Guide ကို ဒီမှာ Download ချပါ။ Zawgyi to Unicode Converter
Don't share ebook or software if nobody request. You can find free book websites on here. We are welcome for discussion or asking question instead.

Cannot install GD library and error shows Missing Dependency: php-common = 5.1.6-43.el5_10

edited February 2014 in Linux/Unix

JpGraph ကို Bar graph လုပ်ဖို့မှာသုံးတာ ။ GD library မရှိဘူးဆိုပြီးပြောပါတယ် ။ အောက်က Error တက်ပါတယ် ။

JpGraph Error: 25001 This PHP installation is not configured with the GD library. Please recompile PHP with GD support to run JpGraph. (Neither function imagetypes() nor imagecreatefromstring() does exist)

Php version က 5.3.5 နဲ့ OS က CentOS သုံးနေပါတယ်။
GD Library ကို
yum install php-gd သုံးပြီး Intall လုပ်တော့ php-common-5.1.6-43.el5_10 ရှိမှ Intall လုပ်လို့ရမယ်ဆိုပြီးတော့ Error တက်လာပါတယ် ။ အောက်က Error တက်ပါတယ် ။

php-gd-5.1.6-43.el5_10.x86_64 from updates has depsolving problems

--> Missing Dependency: php-common = 5.1.6-43.el5_10 is needed by package php-gd-5.1.6-43.el5_10.x86_64 (updates)

Error: Missing Dependency: php-common = 5.1.6-43.el5_10 is needed by package php-gd-5.1.6-43.el5_10.x86_64 (updates)

အမှန်ဆိုရင် php-common-5.3.5-1.el5.remi.1 ကသွင်းထားပြီးသားပါ ။ ဘာဖြစ်လို့ php-common-5.3.5 ကို Dependency မလုပ်ဘဲနဲ့ php-common-5.1.6 ကိုသွား Dependency လုပ်နေလဲဆိုတာ စဉ်းစားမရပါဘူး ။

phpinfo() မှာသေချာအောင် စစ်ကြည့်တာ GD Library မရှိပါဘူး ။

yum info php-gd Repo မှာ updates ပဲပြနေပါတယ် ။ သွင်းပြီးရင် Installed ပြပါတယ် ။

Loaded plugins: fastestmirror

Loading mirror speeds from cached hostfile

* addons: mirror.nus.edu.sg

* base: mirror.nus.edu.sg

* extras: mirror.nus.edu.sg

* updates: centos.ipserverone.com

Available Packages

Name : php-gd

Arch : x86_64

Version : 5.1.6

Release : 43.el5_10

Size : 119 k

Repo : updates

Summary : A module for PHP applications for using the gd graphics library

URL : http://www.php.net/

License : The PHP License v3.01

Description: The php-gd package contains a dynamic shared object that will add

: support for using the gd graphics library to PHP.



yum info php-common

Loaded plugins: fastestmirror

Loading mirror speeds from cached hostfile

* addons: mirror.nus.edu.sg

* base: mirror.nus.edu.sg

* extras: mirror.nus.edu.sg

* updates: centos.ipserverone.com

Installed Packages

Name : php-common

Arch : x86_64

Version : 5.3.5

Release : 1.el5.remi.1

Size : 5.1 M

Repo : installed

Summary : Common files for PHP

URL : http://www.php.net/

License : PHP

Description: The php-common package contains files used by both the php

: package and the php-cli package.

အကြံကောင်းလေးများ ကူညီကြပါ ။ ကျေးဇူးတင်ပါတယ် ။

Google မှာရှာရင်းနဲ့ အခြေနေခြင်းတူတဲ့ သူနဲ့လာတွေ့ပါတယ် ။ ဒါပေမဲ့ သူလဲအဖြေမရလိုက်ဘူးထင်ပါတယ် ။ သူကတော့ GD သွင်းလို့ဖြစ်တာမဟုတ်ဘဲ Soap သွင်းတဲ့အခါမှာဖြစ်တာပါ ။
http://forums.phpfreaks.com/topic/260751-installing-soap-on-vps-64bit-legacy-common-file-problem/

Tagged:

မှတ်ချက်များ

Sign In or Register to comment.