မင်္ဂလာပါ!

လှိုက်လှဲစွာကြိုဆိုပါသည်။ ယခု ပထမဆုံးအကြိမ် ရောက်ဖူးခြင်းဖြစ်ပါသလား? ဝင်ရောက် ဆွေးနွေး မေးမြန်းလိုပါလျှင် အောက်တွင်ဖော်ပြထားသော button များမှတဆင့် ဝင်ရောက် ဆွေးနွေးနိုင်သကဲ့သို့ အဖွဲ့ဝင်အသစ်အနေဖြင့်လည်း လျှောက်ထားနိုင်ပါတယ်။

MYSTERY ZILLION တွင် English သို့မဟုတ် Unicode ဖြင့်သာ အသုံးပြုခွင့်ရှိသည်။ ဇော်ဂျီ ၊ ဧရာ စသည်တို့ကို အသုံးပြုခွင့် မရှိ။ Unicode fonts များမှာ Mon3,Yunghkio, Myanamr3 စသည်များ အသုံးပြုနိုင်သည်။ Unicode Guide ကို ဒီမှာ Download ချပါ။ Zawgyi to Unicode Converter
Don't share ebook or software if nobody request. You can find free book websites on here. We are welcome for discussion or asking question instead.

Ubuntu မှာ file owner မဖြစ်လို့။

edited January 2012 in Ubuntu
ကျွန်တော် XAMPP ကို Ubuntu မှာသွင်းတာ။ opt ဖိုင်ကို permission ပြောင်းလို့မရဘူး။ You are not owner, so you can't change these permission ဆိုပြီးပေါနေတယ်။ Terminal ကနေလုပ်ဖို့ ဘယ်လိုလုပ်ရမလဲလို့ ၊ ကူညီပါအုံး။။
Tagged:

မှတ်ချက်များ

  • edited January 2012 Administrators
    Let me know how did you install XAMPP? By the way, why do you want to use XAMPP rather than installing MySQL, Apache and PHP separately on Ubuntu?
  • Registered Users
    I only want to use for Apache and PHP.. which are the nice app?
  • Registered Users
    ကျွန်တော် သွင်းလို့ရသွားပါပြီ။ http://freshtutorial.com/install-xamp-ubuntu/
  • edited January 2012 Administrators
    အင်းဗျ တကယ်တော့ XAMPP ဆိုတာက လွယ်အောင်လုပ်ထားပေးတာ အဲဒီတော့ နောက်ဆုံးဆော့ဝဲတွေ မရနိုင်ပါဘူး Windows မှာဆိုရင် သုံးကာစလူတွေ Setup မလုပ်တတ်မှာစိုးတဲ့အတွက် အလွယ်တကူထည့်ထားတာပါ Ubuntu မှာက ဒီအတိုင်းကိုပဲ Setup လုပ်ရတာ လွယ်ပါတယ် အဲဒီတော့ တစ်ခုချင်းထည့်ပါ အောက်မှာ Commands တွေပြထားပါတယ် အဲဒီလို Install လုပ်လိုက်ပါ။

    <pre>
    sudo apt-get update
    sudo apt-get install mysql-server
    sudo apt-get install apache2
    sudo apt-get install phpmyadmin
    </pre>

    အဲဒါဆိုရင် သုံးလို့ရပါပြီ Ubuntu မှာကောင်းတာက Dependencies တွေကိုကိုယ်တိုင်ထည့်တာပါ phpmyadmin ထည့်လိုက်တော့ သူရဲ့ Dependencies တွေဖြစ်တဲ့ php လိုဟာတွေ အကုန်ထည့်ပေးသွားတော့ သိပ်များများလုပ်စရာ မလိုတော့ပါဘူး။

    phpMyAdmin အတွက်က http://localhost/phpmyadmin မှာရှိပါတယ် MySQL အတွက် root user and password တွေက Install လုပ်တုံးက ဘာပေးမလဲမေးခဲ့ပါလိမ့်မယ် အဲဒါနဲ့ဝင်လို့ရပါတယ်။

    Web Sites အတွက်က /var/www အောက်မှာ ဖိုင်တွေကိုထားရင်ရပါလိမ့်မယ် အဲဒါလည်း တစ်ခြားနေရာမှာထားချင်ရင်လည်း ပြောင်းလို့ရပါသေးတယ်။

    Linux မှာတော့ XAMPP မသုံးပါနဲ့ အားမပေးချင်ပါဘူး တကယ်တမ်း Production အတွက်က XAMPP မသုံးလို့ပါ အဲဒါမှသာ Server တွေကို Setup လုပ်တတ်သွားပါလိမ့်မယ်။
  • Registered Users
    ဟုတ်ကဲ့။ အကိုပြောမှပဲ ရှင်းရှင်းလင်းလင်း သိတော့တယ်။ ကျေးဇူးတင်ပါတယ်၊ တကယ်ပါ။
  • Registered Users
    ကျွန်တော် သွင်းပြီးပြီ။ http://localhost/phpmyadmin မရဘူး။။

    Not Found

    The requested URL /phpmyadmin was not found on this server.
  • Administrators
    အင်းခက်တော့ခက်ပြီ အလွယ်ဆုံးနည်းပြောမှ မရတော့ဘူးဆိုတော့ တစ်ခုချင်း ပြန်မေးမှရတော့မယ် :D

    1. MySQL Install လုပ်လို့ရပါသလား။

    mysql --user=root -p

    အဲဒီ့ Command နဲ့ဝင်လို့ရမရစမ်းကြည့်ပါဦး

    2. Apache Install လုပ်လို့ရပါသလား။

    http://localhost ဆိုရင် အနည်းဆုံးတော့ It works! ဆိုတဲ့စာကြောင်းပါတဲ့ Page တစ်ခုတော့ တက်လာရတယ်။

    3. phpMyAdmin Install လုပ်လို့ရပါသလား။

    /etc အောက်မှာ phpmyadmin/ ဆိုတဲ့ Directory ရှိရဲ့လား ကြည့်ပေးပါ။

    4. Install လုပ်တဲ့အချိန်မှာ XAMPP ကိုရော Stop လုပ်ထားရဲ့လား အဲဒါကို Start လုပ်ထားပြီးတော့ Install လုပ်နေတာဆိုရင်တော့ Apache က Install လုပ်ပေမယ့် Start လုပ်မှာမဟုတ်ပါဘူး။
  • Registered Users
    mysql --user=root -p
    လုပ်ပြီးတော့ အောက်က ဟာပေါ်လာတယ်။
    [email protected]:~$ mysql --user=root -p
    Enter password:
    Welcome to the MySQL monitor. Commands end with ; or \g.
    Your MySQL connection id is 47
    Server version: 5.1.58-1ubuntu1 (Ubuntu)

    Localhost လည်း အိုကေတယ်။
    /etc အောက်မှာလည်း phpmyadmin ရှိတယ်
    ကျွန်တော်လည်း အဲ့ဒါကို ပဲစဉ်းစားနေတာ. ဘာလို့ မရလဲလို့ ။

    sudo apt-get install phpmyadmin
    သွင်းတုန်းကတော့ တစ်ခုပေါ်လာတယ် ၂ခုထဲက တစ်ခုကို ရွေးခိုင်းတယ်။ ht... ကျွန်တော် သေချာ မမှတ်မိတော့လို့ Password ထက်တောင်းတယ်။ mySQL password ကိုပြန်ရိုက်ပေးလိုက်တယ်။။
  • Administrators
    အင်းသိပြီ phpMyAdmin ကို Apache နဲ့ Configure လုပ်မလား LightHttp နဲ့လုပ်မလားဆိုတာ ရွေးရတယ် အဲဒီ့နေရာမှာ Apache နဲ့မရွေးခဲ့မိလို့ Configure မလုပ်ပဲ ဖြစ်နေတာပါ တကယ်ကတော့ Manually လုပ်လို့ရပါတယ် ဒါပေမယ့် ရှုပ်နေမယ် အလွယ်ဆုံးနည်းက

    sudo apt-get remove --purge phpmyadmin
    sudo apt-get install phpmyadmin

    အဲလိုဆိုရင် အဆင်ပြေတယ် အကုန်လုံး ပြန်ဖျက်ပြီးပြန်ထည့်လိုက် အဲဒီ့အချိန်မှာတော့ Apache နဲ့ Configure လုပ်ဖို့ Check လုပ်ပေးဖို့မမေ့နဲ့ဦး။
  • Registered Users
    ကျွန်တော် ပြန်လုပ်ပြီးသွားပြီ။ အားလုံးအိုကေသွားပြီ... သေသေချာချာ ရှင်းပြတဲ့ အတွက် ကျေးဇူးတင်ပါတယ်။
  • Administrators
    အိုကေသွားရင် ပြီးတာပါပဲ ဒီလိုမေးခွန်းတွေ လာမေးရင် ကျွန်တော်လည်း ကျေးဇူးတင်ပါတယ် မဟုတ်ရင် ကျွန်တော်လည်း ဖြေစရာမေးခွန်းမရှိရင် စိတ်ညစ်ပါတယ်။
  • Registered Users
    var/www ကို ဘယ်လို့လုပ်ပြီး owner permission ရအောင်လုပ်မလဲ၊
  • Administrators
    sudo chown -R yourusername /var/www
  • KK
    Moderators
    ကျွန်တော် အကြံပေးချင်တာကတော့ Ubuntu မှာ xampp ကိုမသုံးပဲ lamp server အတွက် mysql, phpmyadmin, apache2 တို့ကို ဒီတိုင်း သွင်းစေချင်တယ် ခက်လည်းမခက်ပါဘူး။

    http://www.myanmartutorials.com/tips-2/installing-lamp-on-ubuntu/
  • Registered Users

    please Help Me
    the requested URL /lessons/index.php was not found on this server.
    Apache/2.4.7 (Ubuntu) Server at localhost Port 80

  • Administrators

    @sanwinoo125‌ because you don't have index.php file under lessons folder of your localhost. What is the Document path of your localhost ?

  • edited May 2014 Registered Users
        sudo apt-get update
    sudo apt-get install mysql-server
    sudo apt-get install apache2
    sudo apt-get install phpmyadmin
    

    for file permission

    sudo chown -R yourusername /var/www

    what i do more?
    Please help me @saturngod‌

  • Registered Users

    when i try http://127.0.0.1/lessions/index.php

    Not Found

    The requested URL /lessions/index.php was not found on this server.
    Apache/2.4.7 (Ubuntu) Server at 127.0.0.1 Port 80

  • edited May 2014 Administrators

    @sanwinoo125‌

    /var/www အောက်မှာ lessons ဆိုတဲ့ File တွေရှိရဲ့လား သွားကြည့်ပါဦး မရှိတဲ့ File ကို Request လုပ်နေတာလည်း ဖြစ်နိုင်ပါတယ်။

  • edited May 2014 Registered Users

    i got it... Thank For Help @CalmHill and @saturngod
    apache2 default point has var/www/html/
    i wrong call var/www/
    i want to change default point from var/www/html/ - to - /var www/
    and i only see zawgyi fonts on my firefox. i want to also see myanmar3
    please Help.. Me

  • edited May 2014 Administrators

    @sanwinoo125‌
    I don't think your default root is /var/www/html. Apache's default root on Ubuntu is /var/www. If you can access this URL http://127.0.0.1/html/ , you just need to move all files from html directory to /var/www/ and you may delete the html directory. Otherwise you will need to show me the contents of /etc/apache2/sites-enabled/000-default.conf

Sign In or Register to comment.